Lightroom and Snow Leopard

By Gene McCullagh
September 1, 2009

Snow Leopard, the latest iteration of Mac OS X, arrived on August 28th. Whenever a new operating system arrives we have to research our applications before upgrading. (Don't forget that Windows 7 is coming at the end of October so our Windows colleagues will be facing this very soon as well.)

Luckily, it seems, that Lightroom 2.4 and the Creative Suite 4 applications will run under Snow Leopard. John Nack has posted an FAQ regarding the Creative Suite 4 applications on his blog. Click here for the PDF.

The jury is still out on whether Lightroom 1.41 will function fully in Snow Leopard. So if you are thinking of upgrading to Snow Leopard then now may be the time to upgrade to Lightroom 2.4!

If you want to check out the status of your other applications I suggest you visit the Snow Leopard Compatibility Wiki. Most applications are listed with their compatibility issues so you can plan ahead.

Enjoy the latest big cat from Apple!


You might also be interested in:

News Topics

Recommended for You

Got a Question?